Jailbreak iphone 2.2.1

January 30, 2009

Tips & Tricks

 Version 2.2.1

Apple came out with a new version of their iphone and ipodtouch Firmware on Tuesday January 27, while this update only contains minor bug fixes and no cool updates it is worth updating to take advantage of those fixes. Now thanks to Quickpwn you can now jaibreak the new version. Below are the links you will need for the software and firmware.

in order for the Quickpwn program to work on your computer correctly you need the .net Framework installed on your computer

 

Quickpwn Download

iPhone 1st Generation Firmware download

iPhone 3G Firmware download

iPodtouch Firmware downloadThis will only work for the ipodtouch 1st generation. You can’t use Quickpwn to jailbreak the 2nd generation ipodtouch

12 Responses to “Jailbreak iphone 2.2.1”

  1. Morgan Says:

    Thank you very much for your video about downgrading the iphone 3G 2.2
    So easy with your advice and all is running perfectly.

  2. aramis Says:

    You’re welcome, I appreciate your comments and I’m glad the video helped out.

  3. jj Says:

    can you find a way to jail break a 2nd gen ipod touch

  4. Jimmy Says:

    hi, i watched your Video on how to downgrade the 3G Iphone from 2.2.1 to 2.2, but i’m running in to some problems casue my baseband did not change back to 02.28, and when i Jailbreak with QuickPwn then Unlocked it with YellowSnow, i couldn’t get my Iphone to work with the T-Mobil Sim Card, can you please help me out with this .

    Thank you.

  5. Chris Says:

    Hey I just wanted to tell you that your video has by far been the easiest to watch and undestand! I keep running into an issue when I pull up quickpwn on my computer I am using Vista and I heard you mention something about using XP could that be the problem?

  6. Amanda Says:

    Hey im trying to get jailbreak 2.2.1 to work but i have the ipod touch 1st generation…i want to download it but it wont let me it keeps saying http Forbidden 401..how do i get it to work or am i clicking on the wrong link?

  7. maw Says:

    hi! thanks for your video. im trying to downgrade my iphone now and im pretty sure that i have the iphone 3g but the itunes said it cannot be restored because the firmware is not compatible. how does it happened? so now im dloading the other firmware and hope it may work…

  8. Moe Says:

    Hi there i downgrade my iphone 2.2.1 to 2.2 but i still cant unlock it with the quickpwn could u plls tell wht should i do now

  9. dan crafton Says:

    Hey thanks for this site. It was very helpful trying to downgrade to 2.2 when i accidentally upgraded to 2.2.1. I have an iphone 2g that i have a similar situation with. I am getting an incompatible firmware error. I am trying to jailbreak iphone 2g. would this be different than the 3g??

  10. Roy Says:

    Hi.. I just bought a new iphone 3g and it has the firmware 2.2.1 (5H11) with AT&T service 2.9 and Modem baseband as 02.30.03.. I want to unlock it to use it with any sim when i travel. As i understand that as of now it is possible to jailbreak the 2.2.1, but not possible to unlock the same.

    however, as i saw in ur video and someone told me, I shud downgrade the iphone version to 2.2 and then jailbreak and unlock it using quickpwn, bt as after the downgrade also the baseband would not change – wud i be able to unlock it after downgrade?

    Please help really need it.. thanks you soo much in advance in case you have answer.

  11. Michael Says:

    I tried it and it is stuck at the boot page with the pine-apple logo and its been there for 2hours! it doesnt show up on my computer when you plug it in either and i cant controle it. how do i fix this

  12. Try the iPhone 5 Free Says:

    If you’re living in the us then you could be testing and KEEPING the new iphone 5 NOW >> http://adf.ly/2J4gs

Leave a Reply